DOLLY unsolvable X layer shift (I am desperate)

#1

I built my dolly MK2 prusa clone. It is 24V with MKS gen 1.4 board and TMC2100 drivers, runs Marlin (1.6 but I am not sure now).
Steppers are (Czech made) microcon sx17-1005 (0.52Nm) for all axis and microcon sx17-1003 for extruder (0.3Nm). Vref is set to 1V so it should run on 0.7A and 1A peak. Most steppers are about 65°C during a work and drivers are cooled directly with fans. For print head I used original E3D V6.

It worked for a while and prints was great.
Then occasional layershift on X axis appeared so I lubricated linear bearings with bearing greas. It helped for a while.
Then massive layer shift on X axis appeared so I dissassambled X axis, one of the bearings wasn’t exactly smooth so I replaced it with brand new one. It helped for a short time.
Then some squeaky noise appeared with usual layershift. I find out that it can be (and probably was) idler pulley grinding printed idler part on X axis so I placed small washers between pulley and printed part (washers are in contact just with inner bearing ring) that provide smooth run of idler pulley. It helped with squeaky noise but not much with layer shift. I had a bunch of new linear bearings so I replaced all with smoothest I found. It slides like never. Even just tension of inserted filament in a printhead move it from both sides to center until filament is vertical.
I tried everything I found on the internet (even some obscure advices), I messed with motor pulley, change belt tension (up and down) and because I had a slightly deformed Z axis brackets by heat (to much current for a first prints) I replaced them with spare set and reassambled whole Z axis an I did everything I could to make sure that Z axis are parallel. Finally it helped and I was able to print even bigger and longer prints (longest was about 9h) without any issue. It worked for about 30 - 40 hours.

Then I left the printer untouched (literaly) for 2 weeks and now that bloody X axis layershift is back again. :’(
I am not able to print even smaller parts (size of whistle) without issues (usually point of failure appears under 15 minutes)
So I swapped drivers with Y axis to find out if it can be caused by driver (overheating etc.) without succes.
I find out some tiny strings of filament on my smooth rods and linear bearing. So I disassambled it (again), clean rods and replace all bearings with new ones (again). I even changed stepper with one spare. And nothing.

I don’t understand it. I tried to stop moving printhead with my hand and it moved with whole printer aside. When I hold the frame with second hand I need and huge amount of force to hold it against stepper and start loosing steps.
Last resort for me is that I checked belt if it is okay, it looks OK but i ordered new one just to be sure. Last thing what i didn’t changed is main board. Maybe i can modify firmware to swap X and Y axis ports on board to check if there is some problem in electronics before drivers but if it will not help it doesn’t eliminate possibility of faulty board… I also can buy a second board but that also means that I also can build a completaly new printer according to ammount of spare parts I have now. :-/

It is like an Italian sports car, fun to drive it but spends more time on service then on track.
I am literaly desperate. I am “in a war” with this issue for a few months now and I am loosing one battle after another. Luckily I am not a samurai because in this case I should end my miserable life with honor by seppuku. :-/

I am losing my desire and will to solve it so I will be happy for any advice in this case. :?
Thanks

P.S. I forgot to say that TMC2100 are set to spreadCycle mode (I was not able to use solder jumper so I bridged top of the legs directly with wire) and yes I can add a bit more current but according to previous experience I would like to avoid it because I am afraid of to hot stepper and deformation of printed part.

0 Likes

#2

I am using the tmc2100 on my dolly for thw x and y axsis, too.
i have also layershift on longer print.
I am using currently a ramps 1.6 and 12v.
but i have already 2 mks gen 1.4

One printer is 24v both with a mk42 -> one modded for 24v.
i will see if the layer shift go when switching to 24v.

i also use spread cycle mode.

with extra cooling all is fine

maybe this is a solution for you …

0 Likes

#3

Additional question: Does the layer shift only happen one time, or do you get successive shifts during the print?

-Stefan

0 Likes

#4

Hi,
it is always just one shift at a time… usually in different hight, sometimes it happen few times for a print. For example on the foto… on the left one it is not so visible because i “postprocessed” that print for functional test but there was a shift on start in about forth or fifth layer and then right above that triangle hole. On other prints the shift is pretty obvious. :frowning:
Google Photos

0 Likes

#5

yeah same for me.
it is strange because normally it should skip steps as hell when the drivers are hot.
but only one layer shift happens :smiley:

0 Likes

#6

Driver temperature should’t be a problem. It wasn’t a problem even with Vref 1.4V when 1 of Z steppers attacked surface temperatures about 110°C and melt down my printed bracket.
But I measured temperature on heatsink of all drivers just to be sure and it is about 40°C on all of them when it is cooled only passive (and still keep up working). Normaly in my setup I have a fans directly on it.

0 Likes

#7

so yesterday finally magic blue smoke :smiley:

Should be earlier.
Now i replace the ramps 1.6 with the gen 1.4.

maybe i should not heat the nozzle and the bed at the same time :smiley:
but the prusa mk42 uses much less energy than a MK3 so it should be fine …

0 Likes

#8

Great… but buddy… I would like to find a solution to my problem and adding irrelevant replies to this topic will not help. Thanks :roll:

0 Likes

#9

now i have the same setup as you

0 Likes

#10

there is maybe a issue @ marlin

0 Likes

#11

So for me there were a mechanical issue.
the y carriage slightly scratched the frame.
Using a file solved the problem.

Maybe check if there are any spots on your motion system were it is harder to move for the steppers.

0 Likes

#12

I checked that video but I am not using stealthchop mode.

And about mechanical issues… everything runs smooth as a butter on a hot plate :frowning: I slightly added more current to the stepper and it helps for now. But it is kind of “russian style solution - when hammer doesn’t help try bigger one”.
I don’t get it… my friend built a small Dremel based CNC router on NEMA17 steppers and have no issues with loosing steps during routing where is actualy a bigger resistence from routed material. Why should I loose steps on a movement without any of that kind of resistance? :frowning:

0 Likes

#13

that is strange i was on spread cycle before the board swap.
Now i am running stealth chop again and all is fine.
Maybe bad drivers. It is strange

The scratching on the frame was just only a little at my printer.
On moving the bed by hand there was only a very small resistance in a very small area.

0 Likes

#14

i would guess one of the stepper motors blew a gear. the spindle rotates 4x before using the same tooth so it may go a bit into a print before becoming evident. has happened twice to me and for i3 clones(double check your model still) you can get a new motor for 15-20 bucks on amazon.

0 Likes