Error: Heating failed, printer halted, please reset

whenever I try to heat the heated bed to a target temperature, I get that error 10 degrees before reaching the target. I also noticed that the value of the constant PID_FUNCTIONAL_RANGE in my configuration is 10 by default, and that is the same value as the gap between the actual temperature and the target temperature when I get the error.

I would upload my config but I’m a new user so it doesn’t let me upload it. If you want to know a certain part of my config just let me know and I’ll copy paste it.

I am using 2.0 nightly build on a ramps and arduino mega 2560.

hi do a pid tuning.
Maybe it heat up to slow.

I tried to do PID tunnning and it heated up to the taget temperature fine. I updated the PID values but it still has the same error. I know it’s not a power problem, I am using one of those big mosfets for heated bed modules, and the power supply is 30A which is more than enough. Also if I were to heat it to 60 it would stop at 50 and if I were to heat it at 90 it would stop at 80, that’s why I am certain that it is a firmware problem.

I commented out this line:

#define PIDTEMPBED

and now the heated bed works fine.

1 Like

Yes you need at least one mode for the heated bed enabled:

bang bang or pid.

(pid is the better choice)