Error when compiling Marlin for Rumba Board

#1

Hi
I have installed a Rumba board in a CTC Dual “chinese Clone” after the original decided to go bang. Ive managed to sort somethings out with the help of a member on here but im stuck when compling my Marlin i get the following error i have no idea what it means

“Arduino: 1.8.5 (Windows 10), Board: “Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)”
Build options changed, rebuilding all
In file included from sketch\MarlinConfig.h:40:0,
from sketch\G26_Mesh_Validation_Tool.cpp:27:
SanityCheck.h:296: error: static assertion failed: Movement bounds ([XY]_MIN_POS, [XY]_MAX_POS) are too narrow to contain [XY]_BED_SIZE.
static_assert(X_MAX_LENGTH >= X_BED_SIZE && Y_MAX_LENGTH >= Y_BED_SIZE,
^
SanityCheck.h:1523: error: static assertion failed: DEFAULT_AXIS_STEPS_PER_UNIT has too many elements.
static_assert(COUNT(sanity_arr_1) <= XYZE_N, “DEFAULT_AXIS_STEPS_PER_UNIT has too many elements.”);
^
SanityCheck.h:1524: error: static assertion failed: DEFAULT_MAX_FEEDRATE has too many elements.
static_assert(COUNT(sanity_arr_2) <= XYZE_N, “DEFAULT_MAX_FEEDRATE has too many elements.”);
^
SanityCheck.h:1525: error: static assertion failed: DEFAULT_MAX_ACCELERATION has too many elements.
static_assert(COUNT(sanity_arr_3) <= XYZE_N, “DEFAULT_MAX_ACCELERATION has too many elements.”);
^
exit status 1
static assertion failed: Movement bounds ([XY]_MIN_POS, [XY]_MAX_POS) are too narrow to contain [XY]_BED_SIZE.”

I have checked the bed size 230 x 150 has any members got any ideas to solve this error?

#2

Post your configuration file so we can see the values you have selected.

#3

Hi
Here is my config.h file as requested

#4

image

Seriously ???

#5

I`m new to all of this it was sugested by a member on here to put that number into the config so forgive me for my ignorance

#6
#define DEFAULT_AXIS_STEPS_PER_UNIT   { 94.117, 94.117, 400, 96.275, 96.275}

should be enough precise

#7

Thanks for the info will give it a go

Update i have changed those parameters as sugested but still getting the same error as before

#8

or set only one value for the extruder and set it later with gcode

and try: (you moving range was shorter than the bed size)

// The size of the print bed
#define X_BED_SIZE 230
#define Y_BED_SIZE 150

// Travel limits (mm) after homing, corresponding to endstop positions.
#define X_MIN_POS 0
#define Y_MIN_POS 0
#define Z_MIN_POS 0
#define X_MAX_POS 250
#define Y_MAX_POS 155
#define Z_MAX_POS 155
#9

Hi
Thank you for your help i have managed to get it sorted i needed to enable the following line
#define DISTINCT_E_FACTORS
after doing this it compiled with no errors