Falling Z Axis. MPCNC/Marlin/EstleCam/RepetierHost

When building my MPCNC I used a 4 start lead screw which I believe is my core issue here, but I am looking for a way to keep the stepper motor enabled after my cutting. The DeWalt 660 stays running until manually shut off, so currently the machine is dropping a running tool on it self. I’ve checkes both estle and repetierhost settings and found no m18 or m84 in end code. I’ve set dissableing the stepper on completion to false on Marlin even set the time to 0. Yet all steppers still disable at job end. I can’t find anyway to stop this motor from disabling anywhere else.

it is not in the gcode :wink:

you have to set in in the settings:

$1=255 

(disable stepper idle delay/ always on)

should do it if you use grbl.
Or does it really runs with marlin ?

I’ve got DEFAULT_STEPPER_DEACTIVE_TIME set to 0 with Z set to false, didnt help. But yeah it does run Marlin configured for dual endstops.

I found it, It was repetier host. Printer settings, disable steppers. Was expecting something more difficult I guess. Figures I find it after asking for help when I’ve let it stop me for a few days.

1 Like