Issue setting up Z auto align on a Bigtree SKR v 1.3

Finely started to set up my Hypercube for z auto-align and the first step is setting up both z motors to different drivers. I have altered the configuration_adv.h as below with the second z motor plugged into E1 but it is not responding or moving in any way. Do I also have to change the board.h file? Need some direction on this. I am using a Bigtree SKR 1.3 board. Thanks in advance.
//

// For Z set the number of stepper drivers

//

#define NUM_Z_STEPPER_DRIVERS 2 // (1-4) Z options change based on how many

#if NUM_Z_STEPPER_DRIVERS > 1

//#define Z_MULTI_ENDSTOPS

#if ENABLED(Z_MULTI_ENDSTOPS)

#define Z2_USE_ENDSTOP XMAX

#define Z2_ENDSTOP_ADJUSTMENT 0

#if NUM_Z_STEPPER_DRIVERS >= 3

#define Z3_USE_ENDSTOP YMAX

#define Z3_ENDSTOP_ADJUSTMENT 0

#endif

#if NUM_Z_STEPPER_DRIVERS >= 4

#define Z4_USE_ENDSTOP ZMAX

#define Z4_ENDSTOP_ADJUSTMENT 0

#endif

#endif

#endif