Just Built First Printer - Have Issues with Vertical Stretching

I just finished building my 3D printer based on ITopie - RepRap, after seeing Tom’s YouTube series. It turned out pretty well - especially considering I used a jigsaw instead of a CNC. I used 19mm melamine left over from a kitchen project, NEMA17 steppers and toothed belts from some old printers, and bearings from the parts bin. Although I made the printed parts out of wood, I’ll print the plastic parts later to replace the wood.

Anyhow, it seems to work pretty well as far as movement, temperature, etc. are concerned, but I’m having some problems with the print settings. Here’s a configuration “cube” I printed last night:

I’ve tried changing the value of Z in DEFAULT_AXIS_STEPS_PER_UNIT. I started out with 3200, assuming the RB 17HD5017-20’s from a printer had a step angle of 1.8° and I’m using microstepping of 1/32. Then I tried 6400 thinking maybe the step angle was .9°, which didn’t seem to help. When I tried 1600, the nozzle scraped on the previously printed material. I’m using a Winsinn MK8 hotend and by trial and error have it set at 277 steps/mm.

While the piece IS kind of cool looking, It’s not what it’s 'sposed to be. Any ideas what I’m doing wrong? Any suggestions, tips, hits, etc?

Thanks,
Chip

Hi you can use https://blog.prusaprinters.org/calculator to calculate the steps
and the temperature looks to high

You will also need to know the pitch on your lead screws.

-Stefan

Here’s the lead screw:


It says “spacing 2mm”, so I’m assuming that’s three pitch. Maybe it’s not -I guess I can try coding for the standard 1.25.

Hi. Could you clarify an issue? You say that at 1600steps/mm the nozzle scraped on the previous layer, but you set it at 277steps/mm?
What you need to know about that screw is the number of starts and the pitch. If that is a 4start 2mm pitch lead screw, and your motors have a 1.8° step, at 1/32 microstepping that equals 800steps per mm. The formula is (steps_per_revolution x microstepping)/(starts x pitch) (200 x 32/4 x 2)
What you can also do is move z 100mm at whatever steps_per_mm you want and measure actual distance traveled (lets say 150mm). Then new_steps_per_mm will be old_steps_per_mm x 100/150
Good luck tuning

A few days ago, I just faced the same issue with my Epson printer. When I was trying to print some plastic parts then suddenly it stopped printing and showing an error “epson printer in error state” and it is not working well. I don’t know what the hell is happening but it is not resolving anyhow, Does anyone have any idea that how can I resolve this issue?