New extruder issue?

#1

Okay, after many hours of printing perfectly, suddenly at the start of a print after the G29 the extruder starts to retract the filament all the way out of the hot end when it should be laying down the skirt. I am using an Octoprint setup and have been for all my prints this far.

As far as I know, absolutely nothing has changed in the setup or Marlin. This is happening on prints that have previously succeeded with the same G-Code.

I legitimately have no idea what has happened. Any suggestions would be appreciated.

I don’t want to have to reload the octoprint again since I got it setup and running but at this point, I’m wasting plastic.

A bit more clarification, I tried running a print from pronterface and it did the same thing. I am inclined to believe that it may be related to the printer itself. I’m still not sure why.

#2

Since you have Pronterface, have you tried extruding and retracting the filament manually? This may help isolate the problem. Otherwise, first thing I would check is the extruder wires.

#3

Actually, I have tried that. It extrudes and retracts just fine. 5mm, 20mm, 50mm; no problems at all.

The digging I have found all suggests to add G92 E0 which sets the Extruder to 0 in case it’s trying to retract to it’s perceived “0” position.

That’s going to be my next step unless something else comes up to try. I just cannot understand why it would suddenly be an issue when it has worked perfectly before. I mean the same item I have printed perfectly before now has this issue. It’s wholly confusing.

#4

Post your start gcode.

But my money is on you just needing a G92 E0, as you write.

#5

Here’s the code up to the point where it begins to try extruding correctly.

[code]M190 S60.000000
M109 S215.000000
;Sliced at: Sat 11-11-2017 18:28:23
;Basic settings: Layer height: 0.12 Walls: 1.6 Fill: 10
;Print time: 7 hours 9 minutes
;Filament used: 19.33m 57.0g
;Filament cost: None
;M190 S60 ;Uncomment to add your own bed temperature line
;M109 S215 ;Uncomment to add your own temperature line
G21 ;metric values
G90 ;absolute positioning
M107
M190 S60 ; set bed temperature and wait for it to be reached
M104 S215 ; set temperature
G28 ; home all axes
G29 ; auto bed leveling
G1 Z5 F5000 ; lift nozzle
;Put printing message on LCD screen
M117 Printing…

;Layer count: 71
;LAYER:0
M107
G0 F7200 X30.300 Y23.800 Z0.280
;TYPE:SKIRT
G1 F1800 X167.700 Y23.800 E6.39792
G1 X167.700 Y161.200 E12.79584
G1 X30.300 Y161.200 E19.19376
G1 X30.300 Y23.800 E25.59168
G1 F2400 E21.09168
G1 Z0.905
G0 F7200 X34.900 Y28.400[/code]

More important to me is why would this code, which worked perfectly two days ago, would suddenly require changing. What could have possibly changed?

Thanks!

#6

The G90 in the start gcode puts the extruder into absolute positioning mode- that being, each G1 move with an E command tells the extruder to move TO that E position, not (as in relative mode) to move BY that amount.

Nothing in your start gcode is zeroing the E counter, so the first G1 E6.39792 move (on the skirt) is telling the extruder to move to 6.39792mm - but crucially, the position that it’s moving FROM is unknown.

If you just powered on your printer, it’s probably at 0, and it will probably have the effect you want. However, if you’ve just completed another print, or loaded some filament, or extruded a bit, etc, it may well not be at 0. And if the extruder position at the beginning of your print is greater than 6.39792, then your first E move is a retract.

Add G92 E0 after the G90 line and my bet is it will start working properly.

#7

I plan to add the G92 to test but I’ve run these prints after others previously without issue. Regardless, when I get a chance, I’ll test the G92 and hopefully we’ll have it figured out.

Thanks!

#8

I added the G92 to the print and that seemed to help but it’s still not printing 100%. I’m going to try reslicing all of my prints and go from there.

Thanks all!

#9

So what’s not 100%?

#10

Next question. What would cause the extruder motor, which was working perfectly fine to start jumping between two points instead of normal movement?

The same the thing happens with a different motor as well.

Nothing has changed. No software updates or anything. It just stopped extruding.

#11

What do you mean by jumping between to points? If you mean it’s jittering and vibrating, it’s probably a break in one of the wires or a poor connection.

#12

It bounces back and forth. Jitter may be the best description for it but it never advances forward or back

#13

What I said then; wiring issue.

#14

That was it. Thank you. I’m learning so much about how to fix these silly things.

#15

See page 1, first response. :smiley: