Printer is printing inverted - Problems configuring Marlin

My printer is printing inverted on the Y-Axis and since I cannot change the endstop-positions, I need to change this in Marlin. I googled and got a few answers, but now my endstop is lighting red, but it does not react when homing. (It does not stop the stepper) Here is what I changed so far:

  1. Commented out YMIN

//#define USE_YMIN_PLUG #define USE_YMAX_PLUG

  1. Changed Y-Direction from false to true
#define INVERT_Y_DIR true
  1. Changed endstop from -1 (min) to 1 (max)
#define Y_HOME_DIR 1
  1. I also changed

#define Y_MIN_POS 220 #define Y_MAX_POS 0

#define Y_MIN_POS 0 #define Y_MAX_POS 220
Can someone help me? What did I do wrong?

Did you physically change the endstop plug on the board? That first setting is to tell the firmware which plug to look to for the endstop signal, sounds like maybe it’s still plugged in where it was so it’s lighting up because it has power, but not reacting because the firmware is looking for a signal from the other plug.

To add to what chumm said, test your end stops are working + recognised with GCODE M119 in pronterface.

I didnt even know I had to change that… Woops. Where do I have to plug it in on Ramps 1.4? Are the pins on the Board like this?

Xmin Xmax Ymin Ymax? Do i have to put it on the 4th slot?

I fixed the endstop problem now. Sadly it only lets me move the axis 100mm away from the endstop. Does anyone have an idea why?

You can only move towards the end stop until you’ve homed an axis. Are you sure your axis direction is correct?

Going back to your original post, your inversion issue is probably a slicer issue rather than a firmware issue.

This is what a testcube looks like when I print it normally. This didnt happen before I changed the settings regarding inversion.

It was inversed on standart cura profiles aswell. I couldnt figure out why it was inversed, doesnt really matter now, just trying to fix this last issue now.

Assuming the problem is that you wanted to print that cube in the center of the bed, there’s some issue with where the printer and/or slicer think 0,0 is located. After you home all axes, move the printer to 0,0 and see if it’s in the corner of the bed or the center (or somewhere else entirely). Then check the bed settings in your slicer to see if they match up. This will be easier if you have an LCD, then you can move the axes around and see if the numbers they are reporting make sense, but you can also use M114 in pronterface to get the current values at any time, just make sure you home first.

The printer printed inverted is not expected from a printer. Once my printer also prints inverted form. I am using the HP Designjet T520 printer atleast not expected from this printer. When I read this forum I related the same problem that also happened with my printer. But the problem got solved when I reinstall the driver of the printer.