Prusa firmware for RAMPS Prusa i3 clones with MK42 beds

#81

can you read signatures ? :-/

0 Likes

#82

When I start the 3D Printer appear a message saying something like " the printer is not xyz calibrated". After that I make the calibration. I start printing selecting a correct Z parameter with " live Z adjust".

When I turn off the printer, all parameters are deleted like the statics, live Z adjust parameter, etc. And appear again the message “the printer is not xyz calibrated”

How can I save the values? Thank you for your help.

0 Likes

#83

that one is normal one for 1 extruder, i allready checked…

0 Likes

#84

slippyr4, im planing to build a clone after i install the MK2.5 upgrade, with the parts left from the original. My problem is i have the Graphical LCD and from what i researched, it doesnt work with Prusa firmware. Does the same apllies to this version for the ramps? Wanted to avoid buying a new LCD tbh.

0 Likes

#85

No it won’t work. Prusa stripped support out a long time ago. TBH, i don’t think there would be the code space anyway, but, IMO it’s not a very good idea. The graphical LCD takes a LOT more CPU time to run than a character LCD, and that’s less CPU time for the planner. All so you can get a tiny drawing of an extruder! Not worth it. Buy yourself a character lcd controller, they’re like £/€/$ 10

0 Likes

#86

Roger that m8, thanks for the help on it.

ATM im trying to fix spare frame i have. My MK2S arrived with a bent frame and was replaced with one 100% straight, so im gonna try to use the bent one to build the clone. The bent is not that much, but im not sure if it will influence in the end. Problem is i tried manually fixing and its almost impossible.
Does someone have any idea on how it would be possible to make it close to 100% straight?

0 Likes

#87

The only thing i did was enable the following line

// Prusa Single extruder multiple material suport
#define SNMM

in Configuration_prusa.h

And the above changes in pins.h
Then compile, and done.

0 Likes

#88

@slippyr4 could you help me please?

0 Likes

#89

Does your printer actually finish calibration?

What electronics are you using?

0 Likes

#90

The Eeprom was deactivated. I fix the problems. Thank you!

0 Likes

#91

I’ve now merged v3.1.0 from upstream and fixed bits that needed fixing. You should be able to either pull from the v3.1.0 branch in my repository (if you’re using git), or if you clone/download the code from github now it will be the 3.1.0 version.

By default, linear advance is enabled in the firmware, but it won’t do anything until you set a K-factor your start.gcode (with M900). You’ll need to experiment to find a good K factor for you. There’s lots of info out there on how to do that. For me, I use M900 K50.

0 Likes

#92

Update times, bless you!

0 Likes

#93

Thank you so much!
I have an original MK2S and decided to build the Haribo Mod.
Because i wanted to let the original be as original as possible i sourced my components elsewhere.
Just put 3.1.0 on an MKS Gen 1.4 and it seems to work, still have to put the total assembly together though.
Thank you for your work on this!

0 Likes

#94

I think you need to change the Z height for haribo to work right; that’s all that’s different about their firmware vs stock. it’s a one line change though.

0 Likes

#95

I’m having very weird results. My setup is a clone i3 with RAMPS1.4, 12V PSU running at 13V, 5V inductive sensor, MK42 bed from indiegogo
The setup was working fine with a capacitive sensor and running Marlin. I wanted to take full advantage of the MK42/inductive sensor combo so tried installing this firmware.
1-For some weird reason if I plug the usb onto the computer with the PSU on i get the welcome screen (Original Prusa 3d printers) and the following two screens are garbled text 98% of the time. If the PSU is off when I plug the USB the text is fine. Could it be due to the 13V? Never had issues…
2-When I run the selftest it always crashes at Endstop wiring error Z. The sensor seems to work if I bring a piece of metal close to it…
3-When I try to calibrate XYZ, I follow the instructions to move all the way up, it homes X, Y and then 99% of the time it does not lower the head back to 0. Just tries to find the first spot in X and Y leaving Z at max.
Any ideas?

Cheers!

0 Likes

#96

Am i the only one who has quite a lot of issues with the 3.1.0 FW?
Ive basically just taken over all my changed values from the 3.0.12 FW and did a full EEPROM reset but i still have two dealbreaking issues:

the e-steps seem not to stick. with my Hobgoblin and 32x microstepping i need something around 285 ( which is set but the Printer just doesnt move enough filament ( like more than 50% less)

The Z-Axis speed during movements (homing or manual movement) is a shitton slower, despite using the exact same values in both versions

edit: just doublechecked. went back to my 3.0.12 version and errything works
then cloned the v3.1.0 again and ported my changes over using diff.
then flashed the new and clean 3.1.0 agian, didnt work. cleaned eeprom and recalibrated, still didnt work

edit2: the two FW-sources i used https://1drv.ms/u/s!ApYsHcrAcD--uLUmCuMRwLN3xDI0QQ

0 Likes

#97

I’ve not had any problems at all…

3.0.12 was (deliberately) broken by prusa in that it didn’t save E-steps to EEPROM. I’d “fixed” that in my firmware fork, and, in the community-edition branch it was fixed too.

When I was merging 3.2 from upstream I obviously got conflicts in that section of the code; I reviewed the upstream changes and concluded that they’d restored the ability to save E steps to eeprom, so I did an “accept theirs”, and there are therefore no changes compared to upstream on that part of the code.

I’d be happy to diff my branch vs your branch but I’m unable to open the zip downloaded from your onedrive. You can email it to me if you like, I use gmail.

However, I don’t override the E-steps in eeprom personally - the main branch I maintain in git is the “stock” firmware but I have my own private branch that differs only by my configuration for my printer, and it’s trivial to merge into that branch and consequently I run a “custom” firmware which has, amongst other things, got my E-steps calibration hard coded.

0 Likes

#98

The thing is: M503 gives me the correct esteps. But they don’t seem to apply.
And I can basically rule out an hardware issue as the previous version works just fine

Edit: you might need 7zip to open it, as it’s LZMA-compressed. I’ll change it in a few minutes tho and upload a usual zip

0 Likes

#99

So can you try setting your E steps in DEFAULT_AXIS_STEPS_PER_UNIT in Configuration_prusa.h ?

0 Likes

#100

im already doing that.
FW https://drive.google.com/open?id=1wmBvqIObYU0hYc_bKZohBGmSXIcINPND

0 Likes