RAMPS, TMC2130s, and LCD

#1

If anyone was wondering or stumbles on this later I reassigned the CS pins for X (X_CS_PIN) and Y (Y_CS_PIN) to land on AUX 2 instead, then moved the female connector from the LCD PCB and put it on the RAMPS board itself and put long through male headers on the LCD PCB so I could plug the stepper SPI pins on top. I’ll post a picture once I’m done

0 Likes

#2

Sorta like… this?

http://i3.photobucket.com/albums/y58/greatabyss/IMG_20171218_204953.jpg

I just soldered the SPI pins on top of the existing solder points… not the best idea, but it’ll do for now. What pins did you map your X and Y pins too, 40,42?

Let me know if you have any issues, mine’s been stalling on the second layer (on any print).

0 Likes

#3

Yep that’s exactly what prusa are doing.

0 Likes

#4

Has anyone documented how to use RAMPS with TMC2130s and an LCD yet?

Thanks,
Matt

0 Likes

#5

I have some extra info to my problem that might mean something to someone…

By pushing the kill (stop) button on the MKS GEN board, I got a few error messages:

READ: X driver error detected:
READ: overtemperature
READ: short to ground (coil A)
READ: short to ground (coil B)
READ: Error:Printer halted. kill() called!

UPDATE: There was a splatter of solder on the pot of the driver… I had a spare, and replaced it. Now I have a different issue which I will make a new post.

0 Likes

#6

@oakdesign

So back at the LCD issue, based on your description of pins and connections, and checking the provided adapter, I see that in AUX3 there are 5 pins common to the LCD and TMCs:

49, 50, 51, 52 and 53.

50 is MISO, 51 is MOSI, and 52 is SCK.

Assuming I don’t need to move these two, I only need to move pins 49 and 53, correct?

From what I read, these two pins have to do with SD support. Since I do not have SD support enabled, wouldn’t you think the LCD should be showing up?

Thanks, sorry for the dumb question! I am getting there!!!

0 Likes

#7

So correct MISO,MOSI,SCK are only used by SD, I running of a RAMPS with a LCD12864 and don’t use the SD at all so I don’t use the EXP1,EXP2 adapter on my RAMPS at all. Pin 49 is SD_DETECT_PIN , Pin 53 SDSS so none of these are needed if SD Card is not used,
So with those 8 pins plus GND(white) and 5V(black) my Display is fully functional

0 Likes

#8

Thanks one more for the help.

Okay, saga is over!! I got all to work!! I haven’t tried the sd card feature but after moving those pins and adjusting the firmware, the LCD was still blue… so I grabbed another pne I had borrowed from a friend, and guess what? Yep, mine was bad!

Now I am waiting for heat sinks and fans, and a new LCD, and no more upgrades for a while now!!!

Thanks for all the info and support!

0 Likes

#9

I’m with except of any modified Ramps either for 24V or with cut D1 Diode to whatever Reason (ie fried Arduino Voltage Regulator) than in any Case 5V is supplied from USB

0 Likes

#10

Thank you guys for sticking with me on this!!!

My brain last night, and still today… feels like it is in a knot!!! It is fun though!!!

I will play with this today once back home and see how far I get. It is a slow learning curve but having a direction where to go makes a huge difference!!! If all fails, I will ship this out to one of you guys!!! HAHAHAA!

I may disconnect 3 out of 4 drivers to make it easier and eliminate mistakes…

I will report back later on!! Thanks so much, once more!!

0 Likes

#11

For some first tests you could always use the Arduino sketches from the TMC2130Stepper library used by Marlin and flash one of those first to get a bit of a feeling what and how is possible with those divers.

0 Likes

#12

Okay, I am back! With great news and more questions, off course…

So the printer is alive!! All the axis work, including extruder! What a nightmare with all the wires!! And after I got it to work, I made cleaner connectors but something was bad…had to hunt down one bad little splicer…never happens, right?

I had to start with a fresh clean firmware and added one driver at a time, and bam.

Now, still no LCD. I decided to first get all this working and next will be the LCD.

Thanks a lot for all the help so far!

I just re-read some of your last posts and noticed some warning about how not to burn your drivers… but I didn’t quite get it. Do you mean if you plug in the USB to the computer without powering the board, it will damage the drivers? If so, I did that many times. How do I check for damaged board? Or it would plain not work?

Also, did you say by removing fuse 4 (not sure YET where is it) you can connect the USB to the computer and it won’t power the board? Because that is very annoying to me. I would like the board not to power up just via USB…

I am calling it quits for the night… LCD and hunt for fuse 4 tomorrow!! Ah, here is a pic of the board so far… I need to print a box for this and then clean up the remainder of the wired…

image

0 Likes

#13

Ha, spoke too soon… went to print a benchy just to enjoy the quietness of the motors and after 4 layers, for no reason, it stopped. Message through Simplify was “unresponsive firmware”.

I reflashed the firmware, but now I cannot even heat the bed. Nothing works through simplify. Without panel, can’t move it that way either.

On the communications tab, in simplify, It says it is connected, but cannot send any codes… bricked?

Yep, time to sleep…

: (

0 Likes

#14

@mesnik Concerning your LCD issue. Having alook on the schematics and the board layout it’s quite obvious why a repRaps Full Graphics display will not work on the MKS as the coonnector on the MKS has the notch on the wrong side. So as 5V and GND are fixed no way to reassign the pins. Either cut the notch on the Display ribbon cable or cut a notch slot into the connector on board

0 Likes

#15

Thanks for the note oakdesign. So I did cut the tab on the connectors and I have tried both in every each way possible?!!! So to be clear, I plugged both cables on the MKS with the tabs matching the notches. And on the end of the cables that connect to the panel, I cut the tabs off of both cables and plug them “up side down” into their connectors.

And I have tried all different configurations: tabs matching the notches, criss-crossed… nothing.

Now, I am still fighting my new problem from last night. This morning, after trying all the reboots and re=flashing the firmware, I was only able to get the printer back to talk to simplify was by moving the Z axis by hand, and that did the trick. So I reset everything one more time, moved all the axis around, extruder, heaters, fan… all seemed to be working perfect.

I went for a second attempt to print. This time, it locked up on the second layer. But this time, my Z axis trick didn’t work. I tried activating all the limit switches and even tried to use Repetier… printer is locked up.

Hopefully somebody will have some ideas or some test/checks for me to perform to figure out this puzzle…

I guess this has to be fixed first before getting back to the LCD issue.

THANKS!!

0 Likes

#16

@mesnik
That’s my wiring. Just when I started. Only using 2 X 2130 as I’m currently testing them in a mixed setup with TMC2208. So Green=MOSI,Red=SCK,white=MISO and yellow CS for every driver

0 Likes

#17

Okay, so if I understood you correctly, you are not using the ribbon cables from the LCD to the EXP1 and EXP2. Well, you have a different board than I do… And you moved it to another AUX other than AUX2 and AUX3 which is used for the TMCs drivers.

I have never done the firmware tweak to change and assign different pins… that will be yet another challenge…

0 Likes

#18

Yes i have a RAMPS and I use the LCD ribbon cable just don’t plug it on to the the board. At the moment still connected with the jumper wires as in my image. Diong some reassingment in the Marlin boards pin_XXXX.h is not that big deal best is to have a schematics with the pin layout and numbering on hand.
the jumper wire connection will be replaced with a 10pin connector plug in the next few days

0 Likes

#19

Ok I see you have a MKS Gen. I always have a bit of an issue with those MKS parts as they don’t provide proper documentation. With a pin layout schematic for the board I would be no problem to explain or draw a plan how to wire it up best for a LCD/TMC2130 SPI setup

0 Likes

#20

So the 3 pins marked in red are SCK,MOSI,MISO which are shared and used by every driver. All pins marked in blue can be used as CS pins you just have to take care to set the right pin number in Marlin configuration for the CS pin. And have a look on the LCD EXP1 EXP2 numbering as far as I have in mind the connectors on the MKS are reversed to the pinout of the LCD 12864 that most likely why you don’t get ti to work

0 Likes