Randomly changes position of priting and not working LCD


#1

Hey there,

I have Prusa i3 mk2 clone by Thomas guide… Mine LCD is not working (just backlight is working but no chars on it… SD card is read normally (echo from pronterface)).

Another problem is that when iam printing the printer randomly (its not always same spot, same layer etc.) run out of print area and still priting… as image shows…

If there is any solution i would like to have it…

Thanks a lot,

Sympho


#2

Hi please provide pictures of the wiring otherwise nobody can help you.


#3

Tomorrow I will provide them but first at all I would like to get help for that random printing position…


#4

did you measured the power provided by the stepper drivers?
Are there mechanical issues ?


#5

No i didnt. Nope there are no mechanical issues… It is priting well last time it was around 10 minutes of printing than randomly shifted position on X axis… Than i tried again and it does it after 5 minutes…

Iam using Arduino mega, Ramps 1.4,


#6

stepper drivers.

Couldn’t be problem with communication over Pronterface?

Sorry for 2 posts but i cannot as new member post more than 2 links in one post


#7

maybe the stepper driver overheat


#8

I assume that problem will be with X axis because it shift just on X axis and driver for it is not that hot… I can normally hold finger on it…


#9

Most LCDs have a brightness potentiometer on them. That might be the solution to your missing text.

If you want to rule out Pronterface as a cause, try printing directly from the SD card.

Moorviper is right, post more images when you can.

-Stefan


#10

I tried brightness already but same… I cant try out SD card since i cant see chars on screen or is it possible somehow?
I can send you more photos in a minute :slight_smile:


#11

Photos


#12

And another problem… At screen

Here is link for firmware


#13

PID tuning done ?
otherwise thermal runaway is normal :wink:


#14

For sure nope, what is it btw? :smiley: Iam kinda new to 3D printers i already have one for like year but it was bought as complete just builded by me + i was just playing around with parameters…

I will do as wrote here


#15

Hi Daniel,

It looks like you have two sets of wires coming from the heat bed ports on your RAMPS. Where do they both lead?


#16

Hi stefan,

You think in that green connector on left side? My heated bed has 2 positive pins and 2 negative pins


#17

Ok, just checking about the wires. Sounds good.

Here is Tom’s video for PIDs: Autotuning

PIDs on a 3d printer are a method of reaching proper set temperatures by observing and adjusting the rate of change of temperatures. In other words, its how a printer keeps temperatures stable using a feedback loop.

Thermal runaway means that the printer detected a change in temperature that it was unable to correct, so it turned the power source off to avoid damage/fire etc. Adjusting your PIDs will help avoid this.

-Stefan


#18

OKay i will do tomorrow :slight_smile:
Still need to solve 2 more problems… :smiley: LCD not working (not showing chars or anything but SD card is working)
And that random printing position…


#19

Another thought: put a ferrite bead on your USB cable. It is possible you have noise in the line.


#20

I’ve tried to print from SD (started it from pronterface) but it did just “pre print commands” (home, auto level, print line out of printing area…) and that was all… the lane from print area it done 2 times… than it wrote something like printing 0/0 and stopped… will have a look at home and try it again…

Somehow i cannot compile Marlin project now… Yesterday it was working good and now its failing… Just while compiling…

sketch\Marlin_main.cpp: In function ‘line_to_destination’:
sketch\Marlin_main.cpp:1553:1: internal compiler error: Segmentation fault
}
^
Please submit a full bug report,
with preprocessed source if appropriate.
See http://gcc.gnu.org/bugs.html for instructions.
lto-wrapper.exe: fatal error: C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.19.0_x86__mdqgnx93n4wtt\hardware\tools\avr/bin/avr-gcc returned 1 exit status
compilation terminated.
c:/program files/windowsapps/arduinollc.arduinoide_1.8.19.0_x86__mdqgnx93n4wtt/hardware/tools/avr/bin/…/lib/gcc/avr/5.4.0/…/…/…/…/avr/bin/ld.exe: error: lto-wrapper failed
collect2.exe: error: ld returned 1 exit status
exit status 1
Nastala chyba při kompilaci u desky Arduino/Genuino Mega or Mega 2560.

Finally i have video with my problem… :slight_smile: Also i have noticed that when it changes position of printing it stopped extruding… on pronterface there was 115/-314508 °C…

here

Just now i was priting via SD card… after first layer it wrote in pronterface as shown on screen and stopped

There is also log from pronterface… :slight_smile: when the error writing started the printer went to shifted position + now it went minus Z… = it was at 2.25mm than another layer 1.75mm than i stopped it… :smiley:
Whats going on? :smiley:

2019-02-19 19:30:07,658 - Connecting…
2019-02-19 19:30:08,575 - Printer is now online.
2019-02-19 19:30:32,453 - Reversing 10.000000mm of filament.
2019-02-19 19:31:11,056 - [ERROR] Can’t read from printer (disconnected?) (SerialException): call to ClearCommError failed
2019-02-19 19:31:13,786 - [ERROR] Can’t write to printer (disconnected?) (SerialException): WriteFile failed (WindowsError(5, ‘P\xf8\xedstup byl odep\xf8en.’))
2019-02-19 19:31:27,026 - Disconnected.
2019-02-19 19:31:28,007 - Connecting…
2019-02-19 19:31:28,923 - Printer is now online.
2019-02-19 19:31:30,036 - Loading file: C:\Users\Dan\Desktop\y-idler.gcode
2019-02-19 19:31:30,519 - Loaded C:\Users\Dan\Desktop\y-idler.gcode, 12671 lines
2019-02-19 19:31:30,525 - 2064.13mm of filament used in this print
2019-02-19 19:31:30,526 - The print goes:
2019-02-19 19:31:30,526 - - from 60.00 mm to 140.81 mm in X and is 80.81 mm wide
2019-02-19 19:31:30,526 - - from 0.00 mm to 129.31 mm in Y and is 129.31 mm deep
2019-02-19 19:31:30,526 - - from -0.05 mm to 15.55 mm in Z and is 15.60 mm high
2019-02-19 19:31:30,526 - Estimated duration: 54 layers, 0:26:24
2019-02-19 19:31:38,023 - Print started at: 19:31:38
2019-02-19 19:35:49,335 - Print paused at: 19:35:49
2019-02-19 19:36:27,290 - Reversing 10.000000mm of filament.
2019-02-19 19:36:40,688 - Print started at: 19:36:40
2019-02-19 19:38:49,799 - Print paused at: 19:38:49
2019-02-19 19:38:58,200 - Reversing 10.000000mm of filament.
2019-02-19 19:40:31,257 - SENDING:M84
2019-02-19 19:41:48,250 - Print started at: 19:41:48
2019-02-19 19:46:33,558 - [ERROR] Error:error writing to file

2019-02-19 19:46:33,625 - [ERROR] Error:error writing to file

2019-02-19 19:46:33,631 - [ERROR] Error:error writing to file