Randomly changes position of priting and not working LCD


#25

Based on your screen shot of Pronterface, it looks like you had another thermal shutdown. Your temp is reading 10C lower than your setting. This would definitely cause a halt. You definitely need to set your PIDs and try it again.

-S


#26


Something is definitely wrong with your marlin source.

how did you get it?
downloaded a zip
or git checkout?

i also think when i used stock marlin i used 1 instead of 13 for both
#define TEMP_SENSOR_0 13
#define TEMP_SENSOR_1 0
#define TEMP_SENSOR_2 0
#define TEMP_SENSOR_3 0
#define TEMP_SENSOR_BED 13


#27

Hey there,

I did PID tuning already just added it as start code in slicer because my Arduino IDE is not working somehow…


#28

Downloaded zip I think from Tom’s build guide… :slight_smile:


#29

Anyone with idea? Still not working :frowning:


#30

Are you still unable to compile Marlin and load it onto the Arduino? Are you certain the PIDs you are using in your G-code are being used? (I generally don’t trust those kinds of value changes, they don’t always seem to take.) I also still think that you may have noise in your USB cable, so getting a print to work properly with the SD card will help reduce the possible sources of your problem.


#31

I’ve compiled successfully and went over error with heated bed… I tried printing from SD card but after few layers it stuck and stopped printing. It printed like 10 layers and than wrote as shown into terminal

SD printing byte 7336/352925
SD printing byte 7218/352925
SD printing byte 3657434624/352925
SD printing byte 3657434624/352925


#32

I’ve just tried to print via octoprint server and i received error with reading from SD card
Recv: Error:SD read error
Send: N1330 G1 F2640*127
Changing monitoring state from “Printing” to “Error: SD read error”
Changing monitoring state from “Error: SD read error” to “Offline (Error: SD read error)”
Connection closed, closing down monitor

But the problem is that i was not printinh from SD card… so why it does that?


#33

Dumb question: you wouldn’t happen to be using the SPI pins for you drivers? E.G.: tmc2130s?


#34

I dont know what you mean by that? I builded it exactly as Toms guides… So if he done that me too :smiley:


#35

Ok, what I am thinking is that your LCD unit is sending garbage to the RAMPS/Arduino that may be interpreted as G-code. What would happen if you disconnected the LCD from the RAMPS and tried to print?


#36

When I disconnect the LCD and print it start sending
“Error writing to file”.


#37

I’ll try to disable LCD and SDcard in configuration.h and try to reupload FW… lets see what it will do


#38

So far nothing…

Recv: Error:Thermal Runaway, system stopped! Heater_ID: 0
Recv: Error:Printer halted. kill() called!
Changing monitoring state from “Printing” to “Error: Thermal Runaway, system stopped! Heater_ID: 0 - Printer halted. kill() called!”
Changing monitoring state from “Error: Thermal Runaway, system stopped! Heater_ID: 0 - Printer halted. kill() called!” to “Offline (Error: Thermal Runaway, system stopped! Heater_ID: 0 - Printer halted. kill() called!)”

I’ve done PID tunning and tried to print after reuploading frimware with new values and it did again… What can it cause?
Recv: PID Autotune finished! Put the last Kp, Ki and Kd constants from below into Configuration.h
Recv: #define DEFAULT_Kp 29.34
Recv: #define DEFAULT_Ki 2.71
Recv: #define DEFAULT_Kd 79.32
image


#39

OK so another PID tuning it seems good + after disabling SD and LCD in config. It works pretty well… Now iam at 25% of print done and no errors… just “disgusting” layers but this i can solve by settings


#40

Ok, let us know if the print finishes properly. I suspect you may have a bad display/sd reader.


#41

I stopped it after 50% because layers were really bad… And now i cannot even print second layer cuz of Thermal runaway… even i made another PID tunning…


#42

Still think there is progress. No random position changes? If you get another thermal runaway, try to grab the graph like you did before. Also, when you set the PIDs, did you do it with the extruder fan on? At the second layer, it kicks in and can drop the temperature about 10C, which takes time to recover from. Be sure to run the fan at 255 when setting the PIDs.


#43

Yes after disabling SD + LCD no position changes… :slight_smile: Ok tomorrow i will try today i had no time for it… Yes when i do PID i do it with fan ON (i have 2 fans, one is permanently on and second only while printing). Yes thats the problemy mostly… It prints first layer than drop with like 10C and thermal runaway…


#44

So i ran PID autotune with second fan on and after reuploading firmware the Extruder doesnt wants to increase its temperature… BED is working normally but extruder is not heating up… What can be problem? I tried old PID settings but still nothing…