Randomly changes position of priting and not working LCD


#45

That printer is making fun of me… Now ive tried to start it on just if something changes by time… And Extruder works great but heatbed is not heating… :smiley: WTF is going on?


#46

If you are getting different behaviors from the printer and you haven’t made any additional changes to the firmware, the issue is likely in the hardware. Triple check your wiring, especially at the controller side; those plugs are notoriously bad.


#47

I’ve checked all cables and its all good… Maybe somewhere i have loose conection (ive ordered crimp tools so aim gonna redo cables when they come). In the afternoon i will check it once more and try again printing.


#48

So cables are good… Before when i set heatbed to heat there was red LED shining while heating… now its all the time off… Isnt that problem with Arduino or Ramps?


#49

It definitely could be a controller problem. I remember going through several Arduinos and RAMPS before I had a pair that worked repeatedly.

Are you getting 12V from the heater or extruder leads on the RAMPS?


#52

So finally heated bed working… dont know how but it is… But again thermal runaway… I’ve done PID autotune with front fan on and there are results… but still after it first layer OK but the second failed…

Ive done it little different in slicer settings ive set autofan not always on and its good now… But… The Z axis while printing is lying about position… cuz it did this: https://photos.app.goo.gl/fiw4qmzTxa2ZVYag8


#53

Thanks for the screen shot. Good data. So, I’m still seeing about a 5-7 degree drop near the end of the two printing cycles. It appears that the actual temp is not returning quickly enough to the targeted temp; this is what would cause the thermal shutdown. I think, by default, Marlin gives the printer 60 seconds to return to target. The setting is somewhere in configuration_adv.h. You could increase this to 90 seconds to see if it fixes the problem. BUT, PLEASE BE CAREFUL WITH THIS SETTING. Your printer’s ability to detect actual thermal runaways will be slightly compromised because it would take longer to detect an undesired temperature change. Another option is to reduce the normal speed of your cooling fan.

The problem you are having with the z-axis is likely caused by your threaded rods. They introduce a little wobble. Watch them carefully as you print: are they slightly bowed?

-S


#54

Thanks for reply,

As i said in prev. post i set to let slicer automatically chose what power of fan and when to use it… and it was OK, drop was just like for 5°C so thats not much and it vent good… :slight_smile:

Yes Z axis is wobling and now i dont know if bowed i will have a look in the afternoon, but that wobbling would not cause that Z height is not increasing or dropped by few tenth of mm down… Or yes? I have another 3D printer (TronXYZ100 / Startt iMakr) and Z axis is wobbling aswell but the 3D print is really good on that cheapo printer.


#55

A few more thoughts:

  • Double check that your couplers are tight.
  • Are you using z-hop?
  • Have you calibrated your z movement?

#56

Couplers are tight.
What are zhops? And nope… will have a look on it now


#57

Oh, I Google it… no iam not… at first I had 0.6mm on layer change than disabled it but still same… today I did calibration but had no more time for test tomorrow I will try


#58

Calibrated all axis… X,Y is good… i printed 20x20x20 cube and result is 20x20x20.7… The Z is good when i home it is at 177 mm and when i go up to 277mm its at 276.75mm… so its not that bad… How can be result that bad on 20x20x20 cube? + at 14.4mm of print height it started melting down again for 4mm and than 1.6mm again good…


#59

Okay few more edits… and pretty much good first print i think… https://photos.app.goo.gl/wB7EyrSMeZBDBtnR9

Uhm just question… If iam using Bilinear auto bed leveling… isnt the printer supposed to use it while printing? I mean like to continuosly change the layer height of print?


#60

Yes, but do not use home all (G28) after auto leveling. G28 will disable these settings. (M420 S1 will re activate it.)


#61

Aaaaahaaa :smiley: okay ty