Use tmc2130 without spi in stealthchop

#1

Hello,
My name is Mathias, I’m from Germany and new at this place.
Maybe it’s a dump question, but how can I use the tmc2130 without the spi interface in stealthchop? The board i use at the moment doesn’t have that AUX pins… In future I will buy one that has the pins, but now i have to work without the spi.
Do I have to solder all forteen pins to the tmc2130 and just plug it in, or leave some out similiar to the tmc2100? And what’s to do with the three jumper connectors on the chip socket? Am I right that all have to be removed?

Sorry for my rusty english, havn’t used it a long time :?

And thanks for your answeres :slight_smile:

#2

Depends which TMC2130 sou have. If Watterott you have to close the SPI solder Bridge in order have them in standalone. In order to have stealthchop in standalone enabled if the pins are already presoldered you have to cut or desolder the CFG1 pin.

Kannst mich auch per PN in Muttersprache kontaktieren ich habe schon über 6 Monate intensive Erfahrung mit allen TMC Treibern.

The reason why for stealthchop CFG1 pin gas to be removed as with the MS1 jumper open the CFG1 would be connected to Ground and therefore spreadcycle is enabled

#3

Hi and thank you for your answer,
I have the tmc2130 from watterot. So If I understand it right, I have to solder the both standalone Pins together and left the cfg1 Pin unused. The Jumpers can stay in place then?

PN Sounds great but I can’t find the right button^^’ First Time for me in a forum, sorry…

#4

This is the SPI Bridge that you have to solder close in order to set the 2130 into standalone mode

For stealthchop ths pin has to be left away

like this

Private Message buttons

#5

Hello again,
thank your for the pics, I will try it today and will post the results :slight_smile:
The PN button isn’t here on my page, don’t know why…

image

#6

Hi, I had set the tmc like on the pics, but he and the stepper motor made a very high sound, so I shut the printer of. After that I looked again on the schematics an layout files from watterot https://github.com/watterott/SilentStepStick/blob/master/hardware/SilentStepStick-TMC2130_v11.pdf and thank to you I know now what standalone mode is ande how the pins work. In the schematics there is a table where you can see that for stealth mode CFG1 AND CFG2 have to be removed. I tried this and now there is NO SINGLE noise when the stepper motor works :smiley: it’s so smooth and silent it’s incredible! :lol:

thanks for your help, I’m so happy with this :smiley:

#7

CFG2 PIN does not have to be removed. As it connects to the MS2 Bridge. If no Jumper is on the MS2 on the board the pin is left open.
The high pitch sound you encounter in spreadcycle is most likely due to a stepper motor with high Impendance. You can reduce or even get rid of the pitch noise in spreadcycle by pieeri g VMOT with more than 18V. I personally have my TMC connected with an 12-35V step up converter and having them powered with 28V

#8

Mhh…the Jumpers are All in place. I had Just solderd the standalone Pins together and left the cfg1 Pin Open. Thought that’s stealthchop? But Than there was that high Sound. As I left the cfg2 Pin Open too, the Stepper moves silent.
Maybe its caused on my Board? Its a GT2560 Rev b from geeetech…unfortunately there are Just schematics vor the Rev a Board…

#9

The GT2560 is based on the RAMPS. If you leave all jumper on the board MS1, MS2 and MS3 are connected to VCC. So if you left the all Jumpers in place and the CFG2 pin on the TMC2130 as well your CFG2 was not open but conected to VCC and CFG1 was conected to Vio as well resulting to run the driver in spreadcycle without interpolation,
If you would have removed all jumpers from the Board MS2 and MS3 are open = connected to nothing and in consequence CFG2 and CFG3 as well. Only MS1 Jumper is different if the Jumper is removed as my schematics schows above it connects MS1 to GND and therefore if the CFG1 header pin is in place CFG1 is connected to GND as well which results into spreadcycle mode with 1/256 interpolation.

#10

Okay…to be honest I’m not good at those things^^’ thanks for your patience.
So I Have to add the cfg 2 Pin again to the chip, but remove all Jumpers on the board…and if I add the Ms1 Jumper alone, the chip goes in spreadcicle?

#11

your getting closer maybe a visual approach is better I’ll make a few images might explain it better.
So basically if you have the 2130 in standalone (no SPI) the only 2 pins that change the configuration/mode are CFG1 and CFG2.
As you most likely want either spreadcycle in 1/16 microstepping with interpolation or steathchop with 1/16 interpolation the 2 configs are
spreadcycle
CFG1 -> GND CFG2-> open
steathchop
CFG1-> open CFG2 ->open
the rest I’ll explain with some images in a few minutes

#12

Maybe this makes it clear. Remove all jumper and switch between spreadcycle = all Header pin on the driver
or steathchop = remove (desolder or cut) CFG1 pin.

#13

Is SPI useless or unconfigured on the ramps board?

#14

Ahh ok I belive I got it.
So the cause why I thought It works with both pins removed was that removing cfg2 or Ms2 have the same result.
And cfg1 works different. If Ms1 is plugged in and cfg1 is not removed, it “disconnect” cfg1 from gnd, but then it’s still connected to Vio. Ms1 switches the connection between cfg1 to gnd or cfg1 to Vio.

So I remove for both modes ( stealthchop and spreadcicle) all three jumpers,
for spreadcicle I let cfg1 on the chip (cfg1 is connected to gnd), cfg2 is open cause ms2 is open),
to switch so stealthchop I have just to remove cfg1 (cfg1 is not connectet to gnd or Vio, cfg2 is open cause ms2 is open).

I hope I got it know^^’

#15

Yes thats correct now :smiley:

#16

Eureka! :smiley: I really got it! Thank you thousend times for your Help an patience!!!

#17

Soooo…Here I am again…when I setup all things like I think I should, the stepper motors move but with a noisy hum…
I have tried it with adjusting Vref. It’s set to 1V now, but without a better result…

Do I have to change something in the firmware? I thought the changes that Tom did in his tmc2130 video are just needed when the spi is jused.

I really can’t Tell what it could be else…but I’m a little bit worried to damage something, if I change Something randomly.

#18

ok and the chip gets hot on this setup ._.
Just have let the stepper move a little bit (and without any belt on it) to test.

#19

Hi !
Thanks to Oakdesign for this very complet explanation !
I put my two 2130 in standalone mode, one in spreadcycle, one in stealthchop and I’ve got a strange behaviour: they both put my motors at an extremly high speed/travel. I divided by 10 the step/mm in conf.h (Marlin2.0) as same result.
Do you think I miss something with jumpers configuration ?
One stepper have MS1,MS2,MS3 open (spreadcycle) and the other have the same with CFG1 pin unsoldered (Stealthchop).

#20

Hi, you said you have experience with the TMC 2130s?

I’ve got two of those drivers (from watterott) for the x and y axis of my Tevo Tarantula with the gen l motherboard. I’m quite new to this topic and I’m struggling with setting them up.

I soldered on the pins like Tom explains in his video and defined the drivers for the x and y axis in the latest version of Tarantula Marlin, but I’m not sure what to change in the settings. I have tried the default pinout according to a schematic I found online. It didn’t work. The steppers didn’t move. I then defined the SPI pins I used and tried again. It didn’t work.

I also tried many combinations with the features enabled or disabled. It didn’t work.

Do you know a solution? Did I forget something? How can I make sure the drivers are working?

Help would be appreciated.