YABI - Yet another bed-leveling issue

Hi folks,

I am having a bit of an issue with my ABL. After using ABL the firs layer at the very front of the bed (y-axis) is perfect, but at the back it barely even sticks. I’ll try to structure this post a little to make it easier.
I am very much out of ideas and it would be great if anybody could sanity check my configs and my setup.

  1. Setup

I recently upgraded my Tevo Tarantula printer with a new SKR 1.4 Turbo board and TMC2209 stepper drivers. I previously was running the default setup with what I beleieve is a first gen MKS board running Marlin 1.0.x

Now I’ve pulled the current version of Marlin from git, configured my board and all the setting/features and also set up a BLTouch Smart v3.1 for the ABL. I set it up using the bilinear method since I’m mostly printing on glass and I expect that to be decently straight.
The hotend is mounted on a mgn rail with a aluminum carrier (by Taralu). The BLTouch is mounted on the backside where the excenter nuts for the wheels would normally go.
The offset is set to -46mm on the y-axis and from the points the probe takes it seems to be accurate. The z-offset was measured by homing all axis, moving the nozzle to the center of the bed at z=0 and then going downwards from that point (disabling soft end stops temporarily).
The z-offset is -2.85mm. From what the mesh looks like it seems to be accurate.

configuration.h
configuration_adv.h

  1. The issue

I first manually level my bed to make sure the ABL doesn’t need to compensate for too much, as I’ve read that could cause issues. I added G-code to my Cura starting g-code in order to home, auto level and start printing.

This is the code
M117 Heating bed...
M140 S{material_bed_temperature_layer_0} ;set bed temperature
M190 S{material_bed_temperature_layer_0} ;wait for bed temperature

M117 Leveling...
M155 S30 ; Dont talk so much
G28      ; home all axis
G29      ; auto bed leveling
M500     ; store leveling result
M501     ; restore the saved result
M155 S3  ; Talk more again

M117 Heating hotend...
M104 S{material_print_temperature, 1} ; set hotend temperature
M109 S{material_print_temperature, 1} ; wait for hotend temperature

;Put printing message on LCD screen
M117 Printing...

When the print start, I can already see at the skirt lines that the compensation is wrong towards the back of the bed. I also attached pictures of the latest mesh as well as the printed result. Since I printed with clear PLA, I also made a picture of it behind a dark background for more visibility.

  1. What have I tried?

I tried setting the whole thing up with UBL instead of linear leveling, but to no avail. The result is exactly the same as with bilinear.
The I made sure all my screws are tightened and there is nothing loose. While the screws for the BLTouch seemingly were not very tight, they weren’t loose and further tightening didn’t make a difference.
I then browsed around for people with similar issues and stumbled accros a post that mentioned a “rolling motion along the axis” which could result in inaccurate readings. But then again people would have this issue with their x-axis only.
It all doesn’t make sense to me at the moment…

I would attach more pictures if I could. I can share some of my setup and the probe as well as the generated mesh, if anyone is interested.

Any idea and/or help is appreciated.

Sidenote: The scratches on the glass are on the backside which had hairspray on it. I usually use a oven scraper with a blade to clean off leftover filament. No worries here, it just looks weird. For this print I was using the other side which I had cleaned with Isopropanol.